NetScaler ADC / Gateway 14.1 vulnerabilities
11 advisories affect Citrix NetScaler ADC / Gateway 14.1, 11 already exploited by attackers. Latest: October 4, 2026.
Running NetScaler ADC / Gateway 14.1 devices? Get an email when a new vulnerability comes out. Free, unsubscribe in one click.
Turn on NetScaler ADC / Gateway 14.1 alerts
Turn on NetScaler ADC / Gateway 14.1 alerts
| Vulnerability | Severity | Affected versions |
|---|---|---|
| Citrix NetScaler Improper Restriction of Operations within the Bounds of a Memory Buffer Vulnerability CVE-2026-88779 · October 4, 2026 | High 7.5 Exploited | before 14.1-73.41; before 14.1-73.41 FIPS; before 14.1-73.41 Fixed in 14.1-73.41, 14.1-73.41 FIPS |
| Citrix NetScaler Improper Input Validation Vulnerability CVE-2026-88771 · September 27, 2026 | Critical 9.8 Exploited | before 14.1-73.37; before 14.1-73.37 FIPS; before 14.1-73.37 Fixed in 14.1-73.37, 14.1-73.37 FIPS |
| Citrix NetScaler Improper Restriction of Operations within the Bounds of a Memory Buffer Vulnerability CVE-2026-88772 · September 27, 2026 | High 8.1 Exploited | before 14.1-73.37; before 14.1-73.37 FIPS; before 14.1-73.37 Fixed in 14.1-73.37, 14.1-73.37 FIPS |
| Citrix NetScaler Authentication Bypass Using an Alternate Path or Channel Vulnerability CVE-2026-19490 · September 9, 2026 | Critical 9.8 Exploited | from 14.1 to 14.1-73.32 (NVD: 73.32 (included); CPE partly lists it as excluded); from 14.1 to 14.1-73.32 (NVD: 73.32 (included); CPE lists it as excluded) |
| Citrix NetScaler ADC and NetScaler Gateway Improper Restriction of Operations within the Bounds of a Memory Buffer Vulnerability CVE-2026-8452 · August 26, 2026 | Critical 9.8 Exploited | from 14.1 to before 14.1-72.61 (incl. 14.1-66.68); from 14.1 to before 14.1-72.61 Fixed in 14.1-72.61 |
| Citrix NetScaler Out-of-Bounds Read Vulnerability CVE-2026-3055 · March 30, 2026 | Critical 9.8 Exploited | 14.1 before 14.1-60.58 Fixed in 14.1-60.58 |
| Citrix NetScaler Memory Overflow Vulnerability CVE-2025-7775 · August 26, 2025 | Critical 9.8 Exploited | from 14.1 to before 14.1-47.48 Fixed in 14.1-47.48 |
| Citrix NetScaler ADC and Gateway Out-of-Bounds Read Vulnerability CVE-2025-5777 · July 10, 2025 | High 7.5 Exploited | 14.1 before 14.1-43.56 Fixed in 14.1-43.56 |
| Citrix NetScaler ADC and Gateway Buffer Overflow Vulnerability CVE-2025-6543 · June 30, 2025 | Critical 9.8 Exploited | 14.1 before 14.1-47.46 Fixed in 14.1-47.46 |
| Citrix NetScaler ADC and NetScaler Gateway Buffer Overflow Vulnerability CVE-2023-6549 · January 17, 2024 | High 8.2 Exploited | 14.1 before 14.1-12.35 Fixed in 14.1-12.35 |
| Citrix NetScaler ADC and NetScaler Gateway Code Injection Vulnerability CVE-2023-6548 · January 17, 2024 | Medium 5.5 Exploited | 14.1 before 14.1-12.35 Fixed in 14.1-12.35 |
Affected versions are compiled automatically from vendor advisories and NVD and may contain errors. Where no fixed version is shown, you will find it in the official advisory linked from every page: check it there before updating.