CVE-2025-7775CitrixFirewall and VPNAugust 26, 2025

Citrix NetScaler Memory Overflow Vulnerability

Critical 9.8Actively exploited

Description

Citrix NetScaler ADC and NetScaler Gateway contain a memory overflow vulnerability that could allow for remote code execution and/or denial of service.

What to do

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Running Citrix devices? Get an email when a new vulnerability comes out. Free, unsubscribe in one click.
Turn on Citrix alerts

Details

Vendor
Citrix
Product
NetScaler ADC e NetScaler Gateway
CVE
CVE-2025-7775
Affected versions
NetScaler ADC 12.1: from 12.1 to before 12.1-55.330 — fixed in 12.1-55.330
NetScaler ADC 13.1-FIPS/NDcPP 13.1: from 13.1 to before 13.1-37.241 — fixed in 13.1-37.241
NetScaler ADC 13.1: from 13.1 to before 13.1-59.22 — fixed in 13.1-59.22
NetScaler ADC 14.1: from 14.1 to before 14.1-47.48 — fixed in 14.1-47.48
NetScaler Gateway 13.1: from 13.1 to before 13.1-59.22 — fixed in 13.1-59.22
NetScaler Gateway 14.1: from 14.1 to before 14.1-47.48 — fixed in 14.1-47.48 (from the advisory and NVD; check the exact builds in the official advisory)
CVSS score
9.8
Actively exploited
Yes, listed in the CISA Known Exploited Vulnerabilities catalog
CISA due date
August 28, 2025 (deadline for US federal agencies: a good benchmark for you too)
Source
CISA KEV – original advisory
Published
August 26, 2025

The description and the recommended action are quoted from the public advisory; severity, exploitation status and affected versions are compiled automatically from public sources and may contain errors. The vendor's original advisory prevails: check it before taking action. This information is provided without warranty and does not replace a professional assessment.

More Citrix advisories