CVE-2025-6543CitrixFirewall and VPNJune 30, 2025

Citrix NetScaler ADC and Gateway Buffer Overflow Vulnerability

Critical 9.8Actively exploited

Description

Citrix NetScaler ADC and Gateway contain a buffer overflow vulnerability leading to unintended control flow and Denial of Service. NetScaler must be configured as Gateway (VPN virtual server, ICA Proxy, CVPN, RDP Proxy) OR AAA virtual server.

What to do

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Running Citrix devices? Get an email when a new vulnerability comes out. Free, unsubscribe in one click.
Turn on Citrix alerts

Details

Vendor
Citrix
Product
NetScaler ADC e Gateway
CVE
CVE-2025-6543
Affected versions
NetScaler ADC 13.1: 13.1 before 13.1-59.19 (13.1-37.x before 13.1-37.236) — fixed in 13.1-59.19
NetScaler ADC 14.1: 14.1 before 14.1-47.46 — fixed in 14.1-47.46
NetScaler Gateway 13.1: 13.1 before 13.1-59.19 — fixed in 13.1-59.19
NetScaler Gateway 14.1: 14.1 before 14.1-47.46 — fixed in 14.1-47.46 (from the advisory and NVD; check the exact builds in the official advisory)
CVSS score
9.8
Actively exploited
Yes, listed in the CISA Known Exploited Vulnerabilities catalog
CISA due date
July 21, 2025 (deadline for US federal agencies: a good benchmark for you too)
Source
CISA KEV – original advisory
Published
June 30, 2025

The description and the recommended action are quoted from the public advisory; severity, exploitation status and affected versions are compiled automatically from public sources and may contain errors. The vendor's original advisory prevails: check it before taking action. This information is provided without warranty and does not replace a professional assessment.

More Citrix advisories