Ivanti Endpoint Manager Mobile (EPMM) Code Injection Vulnerability
Description
Ivanti Endpoint Manager Mobile (EPMM) contains a code injection vulnerability in the API component that allows an authenticated attacker to remotely execute arbitrary code via crafted API requests. This vulnerability results from an insecure implementation of the Hibernate Validator open-source library, as represented by CVE-2025-35036.
What to do
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Turn on Ivanti alerts
Details
- Vendor
- Ivanti
- Product
- Ivanti Endpoint Manager Mobile (EPMM)
- CVE
- CVE-2025-4428
- Affected versions
- Ivanti EPMM 11.12: before 11.12.0.5 — fixed in 11.12.0.5
Ivanti EPMM 12.3: from 12.3.0.0 to before 12.3.0.2 — fixed in 12.3.0.2
Ivanti EPMM 12.4: from 12.4.0.0 to before 12.4.0.2 — fixed in 12.4.0.2
Ivanti EPMM 12.5: 12.5.0.0 (from the advisory and NVD; check the exact builds in the official advisory) - CVSS score
- 7.2
- Actively exploited
- Yes, listed in the CISA Known Exploited Vulnerabilities catalog
- CISA due date
- June 9, 2025 (deadline for US federal agencies: a good benchmark for you too)
- Source
- CISA KEV – original advisory
- Published
- May 19, 2025
The description and the recommended action are quoted from the public advisory; severity, exploitation status and affected versions are compiled automatically from public sources and may contain errors. The vendor's original advisory prevails: check it before taking action. This information is provided without warranty and does not replace a professional assessment.
More Ivanti advisories
- Ivanti Connect Secure Missing Authentication for Critical Function Vulnerability
- Ivanti Connect Secure Generation of Predictable Numbers or Identifiers Vulnerability
- Ivanti Connect Secure Authentication Bypass by Spoofing Vulnerability
- Ivanti Sentry OS Command Injection Vulnerability
- Ivanti Endpoint Manager Mobile (EPMM) Improper Input Validation Vulnerability