CVE-2024-38813VMwareServers and softwareNovember 20, 2024

VMware vCenter Server Privilege Escalation Vulnerability

High 7.5Actively exploited

Description

VMware vCenter contains an improper check for dropped privileges vulnerability. This vulnerability could allow an attacker with network access to the vCenter Server to escalate privileges to root by sending a specially crafted packet.

What to do

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Running VMware devices? Get an email when a new vulnerability comes out. Free, unsubscribe in one click.
Turn on VMware alerts

Details

Vendor
VMware
Product
VMware vCenter Server
CVE
CVE-2024-38813
Affected versions
vCenter Server 7.0: 7.0 GA – 7.0 Update 3s
vCenter Server 8.0: 8.0 GA – 8.0 Update 2d
Cloud Foundation: from 4.0 to before 5.2 — fixed in 5.2 (from the advisory and NVD; check the exact builds in the official advisory)
CVSS score
7.5
Actively exploited
Yes, listed in the CISA Known Exploited Vulnerabilities catalog
CISA due date
December 11, 2024 (deadline for US federal agencies: a good benchmark for you too)
Source
CISA KEV – original advisory
Published
November 20, 2024

The description and the recommended action are quoted from the public advisory; severity, exploitation status and affected versions are compiled automatically from public sources and may contain errors. The vendor's original advisory prevails: check it before taking action. This information is provided without warranty and does not replace a professional assessment.

More VMware advisories